Notice: Undefined index: amp-core-end-point in /home/applea10/public_html/wp-content/plugins/accelerated-mobile-pages/templates/features.php on line 203

Notice: Undefined index: amp-core-end-point in /home/applea10/public_html/wp-content/plugins/accelerated-mobile-pages/templates/features.php on line 5120
iOS 11 لن يدعم الايفون 5 والايباد 4؟ | ابل بالعربي
Notice: Undefined index: amp-core-end-point in /home/applea10/public_html/wp-content/plugins/accelerated-mobile-pages/templates/features.php on line 203

Notice: Undefined index: amp-core-end-point in /home/applea10/public_html/wp-content/plugins/accelerated-mobile-pages/templates/features.php on line 5120
الايفون 5 الأسود من الخلف

iOS 11 لن يدعم الايفون 5 والايباد 4؟

تخطط شركة Apple للحد التدريجي من خواص الأجهزة التي تعمل بمعالجات 32-بت مثل الايفون 5 والايباد 4، والخطوة المقبلة لقتل هذه الأجهزة قد تكون عدم دعمها في تحديث iOS 11 الذي سيصدر في نهاية عام 2017، هذا ما يلمّح إليه نظام iOS 10.3 في رسائل تظهر لبعض المستخدمين.

الايفون 5 الأسود من الخلف

بعد التحديث لـ iOS 10.3 التجريبي، لاحظ عدد من المستخدمين أن فتح بعض التطبيقات يؤدي إلى ظهور الرسالة التالية:

This app will not work with future versions of iOS. The developer of this app needs to update it to improve its comparability.

هذا التطبيق لن يعمل بإصدارات iOS المستقبلية. على مطوّر التطبيق تحديثه لتحسين توافقه.

التطبيقات التي تظهر فيها هذه الرسالة هي التطبيقات التي لم تدعم بنية 64-بت، أي هي التطبيقات التي لم تحصل على أي تحديث منذ 2013، وهي الفترة التي تم فيها إطلاق الايفون 5s، أول الأجهزة التي دعمت البنية الجديدة. ووفقًا للمطور بيتر ستاينبِرچر، منع التطبيقات المخصصة لأجهزة 32-بت قد تكون خطوة أولية لهدف انعدام أي تحديث لهذه الأجهزة.

إن اتبعت Apple النمط المعتاد، في شهر يونيو المقبل سيتم الكشف عن نظام iOS 11 في مؤتمر WWDC 2017، وعندئذ سيتم التأكد من النوايا النهائية من رسائل عدم توافق التطبيقات.

حاليًا توجد 3 أجهزة تعمل بنظام iOS 10 وبها معالج 32-بت، الأجهزة هي الايفون 5 والايفون 5c والايباد 4 الجيل الرابع، هذه الأجهزة تلقّت تحديثات منذ 2012، أي لمدة 5 سنوات، وعدم دعمها في iOS 11 سيكون منطقيًا.

التعليقات